FamilyThermalProperties.Find Method

FamilyThermalPropertiesFind Method

Finds the thermal properties by the 'id' property of a constructionType node in Constructions.xml.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static FamilyThermalProperties Find(
	Document pADoc,
	string constructionId
)
Public Shared Function Find ( 
	pADoc As Document,
	constructionId As String
) As FamilyThermalProperties
public:
static FamilyThermalProperties^ Find(
	Document^ pADoc, 
	String^ constructionId
)
static member Find : 
        pADoc : Document * 
        constructionId : string -> FamilyThermalProperties 

Parameters

pADoc  Document
The document.
constructionId  String
The 'id' property of a constructionType node in Constructions.xml

Return Value

FamilyThermalProperties
The thermal properties found, or if no match was found.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also