FamilyThermalProperties Class

FamilyThermalProperties Class

A class that contains thermal properties for specific types of families (doors, windows, and curtain wall panels).
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFamilyThermalProperties

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FamilyThermalProperties : IDisposable
Public Class FamilyThermalProperties
	Implements IDisposable
public ref class FamilyThermalProperties : IDisposable
type FamilyThermalProperties = 
    class
        interface IDisposable
    end

The FamilyThermalProperties type exposes the following members.

Constructors
 NameDescription
Public methodFamilyThermalProperties Constructs a new FamilyThermalProperties with default settings.
Top
Properties
 NameDescription
Public propertyAnalyticConstructionName The construction gbXML name. This value corresponds to the 'Name' property of a constructionType node in Constructions.xml.
Public propertyAnalyticConstructionTypeId The construction gbXML type. This value corresponds to the 'id' property of a constructionType node in Constructions.xml.
Public propertyHeatTransferCoefficient The heat transfer coefficient value (U-Value). The units are watts per meter-squared kelvin (W/(m^2*K)).
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertySolarHeatGainCoefficient The solar heat gain coefficient.
Public propertyThermalResistance The calculated thermal resistance value (R-Value). The units are meter-squared kelvin per watt ((m^2*K)/Watt).
Public propertyVisualLightTransmittance The visual light transmittance.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the FamilyThermalProperties
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodStatic memberFind Finds the thermal properties by the 'id' property of a constructionType node in Constructions.xml.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsValid Confirms that the thermal properties are correctly set for assignment to a FamilySymbol.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also