IUpdater Interface

IUpdater Interface

The interface used to create an updater capable of reacting to changes in the Revit model.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public interface IUpdater
Public Interface IUpdater
public interface class IUpdater
type IUpdater = interface end

The IUpdater type exposes the following members.

Methods
 NameDescription
Public methodExecute The method that Revit will invoke to perform an update.
Public methodGetAdditionalInformation Auxiliary text that Revit will use to inform the end user when the Updater is not loaded
Public methodGetChangePriority Identifies the nature of the change the Updater will be performing Used to identify order of execution of updaters Called once during registration of the updater
Public methodGetUpdaterId Returns globally unique updater id - used to identify the Updater Called once during registration of the updater
Public methodGetUpdaterName Returns a name that the Updater can be identified by to the user
Top
Remarks
Implement this interface and register an instance of the derived class with the UpdaterRegistry.
See Also