ImageType.CanReload Method

ImageTypeCanReload Method

Check whether the ImageType can be reloaded from file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool CanReload()
Public Function CanReload As Boolean
public:
bool CanReload()
member CanReload : unit -> bool 

Return Value

Boolean
True if the ImageType can be reloaded. False, otherwise.
Remarks
The test first determines the candidate path for reloading the ImageType. Then the test checks that the corresponding file is a valid image file, that it is unencrypted, and that it contains the page corresponding to PageNumber.
See Also