ImageType Class

ImageType Class

Represents a type containing a raster based image. ImageInstances of this type can be placed in 2D views, sheets, and schedules.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBElementType
      Autodesk.Revit.DBImageType

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ImageType : ElementType
Public Class ImageType
	Inherits ElementType
public ref class ImageType : public ElementType
type ImageType = 
    class
        inherit ElementType
    end

The ImageType type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberExternalResourceType The type of external resources that represents images.
Public propertyHeight The vertical size of the image
Public propertyHeightInPixels Number of pixels in the vertical direction of the image
Public propertyPageNumber The number of the page in a multi-page file, that was used to create the image in the ImageType.
Public propertyPath The path to the file from which the ImageType was loaded.
Public propertyPathType The path type that was used to refer to the file from which the ImageType was loaded.
Public propertyResolution The size of the pixels in the image, expressed in dots-per-inch (dpi)
Public propertySource The source of the image in the ImageType.
Public propertyStatus The status of the image
Public propertyWidth The horizontal size of the image
Public propertyWidthInPixels Number of pixels in the horizontal direction of the image
Top
Methods
 NameDescription
Public methodCanReload Check whether the ImageType can be reloaded from file.
Public methodStatic memberCreate Creates a new ImageType element and loads the image into it.
Public methodGetImageGet the bitmap image stored in the image symbol.
Public methodReload Reloads the ImageType from the file found at the location specified by the Path property, using the same PageNumber and resolution.
Public methodReloadFrom Reloads the image in the ImageType from a new image file, and for a new PageNumber.
Public methodUnload Unload the linked image.
Top
Remarks

ImageType elements are created with the ImageType.Create(Document, ImageTypeOptions) method.

ImageType elements can be loaded from the following file types: *.bmp, *.jpg, *.jpeg, *.png, *.tif.

In addition, when PDF support is available, ImageType elements can also be loaded from *.pdf files. See: IsPDFImportAvailable

See Also