LinePatternSegment(LinePatternSegmentType, Double) Constructor

LinePatternSegment(LinePatternSegmentType, Double) Constructor

Creates a line pattern segment with given type and length.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public LinePatternSegment(
	LinePatternSegmentType type,
	double length
)
Public Sub New ( 
	type As LinePatternSegmentType,
	length As Double
)
public:
LinePatternSegment(
	LinePatternSegmentType type, 
	double length
)
new : 
        type : LinePatternSegmentType * 
        length : float -> LinePatternSegment

Parameters

type  LinePatternSegmentType
The segment type.
length  Double
The length.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
See Also