Revit 2025.3 API
Parameter |
Creates a filter rule that determines whether strings from the document do not
contain a certain string value.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static FilterRule CreateNotContainsRule( ElementId parameter, string value )
Public Shared Function CreateNotContainsRule ( parameter As ElementId, value As String ) As FilterRule
public: static FilterRule^ CreateNotContainsRule( ElementId^ parameter, String^ value )
static member CreateNotContainsRule : parameter : ElementId * value : string -> FilterRule
Parameters
- parameter ElementId
- A string-typed parameter used to get values from the document for a given element.
- value String
- The user-supplied string value for which values from the document will be searched.
Return Value
FilterRuleCreated filter rule object.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
See Also