Revit 2025.3 API
Workset |
Checks if the given workset name is unique in the document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool IsWorksetNameUnique( Document aDoc, string name )
Public Shared Function IsWorksetNameUnique ( aDoc As Document, name As String ) As Boolean
public: static bool IsWorksetNameUnique( Document^ aDoc, String^ name )
static member IsWorksetNameUnique : aDoc : Document * name : string -> bool
Parameters
- aDoc Document
- The document in which the workset is accessed.
- name String
- The workset name.
Return Value
BooleanTrue if this given workset name is unique in the document, false otherwise.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
See Also