WorksetTable Class

WorksetTable Class

A table containing references to all the worksets contained in a document.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBWorksetTable

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class WorksetTable : IDisposable
Public Class WorksetTable
	Implements IDisposable
public ref class WorksetTable : IDisposable
type WorksetTable = 
    class
        interface IDisposable
    end

The WorksetTable type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodStatic memberCanDeleteWorkset Indicates if a workset can be deleted.
Public methodStatic memberDeleteWorkset Delete the specific workset.
Public methodDisposeReleases all resources used by the WorksetTable
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetActiveWorksetId Returns the active workset's WorksetId.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodGetWorkset(Guid) Returns the workset from a input Guid.
Public methodGetWorkset(WorksetId) Returns the workset from a input WorksetId.
Public methodStatic memberIsWorksetNameUnique Checks if the given workset name is unique in the document.
Public methodStatic memberRenameWorkset Renames the workset.
Public methodSetActiveWorksetId Sets the active workset.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
There is one WorksetTable for each document. There will be at least one default workset in the table, even if worksharing has not been enabled in the document.
See Also