Revit 2025.3 API
Workset |
Renames the workset.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static void RenameWorkset( Document aDoc, WorksetId worksetId, string name )
Public Shared Sub RenameWorkset ( aDoc As Document, worksetId As WorksetId, name As String )
public: static void RenameWorkset( Document^ aDoc, WorksetId^ worksetId, String^ name )
static member RenameWorkset : aDoc : Document * worksetId : WorksetId * name : string -> unit
Parameters

Exception | Condition |
---|---|
ArgumentException | aDoc is not a workshared document. -or- name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given workset name is already in use. -or- There is no workset in the document with this id. |
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |
See Also