BuiltInFailures.DividedSurfaceFailures Class

BuiltInFailuresDividedSurfaceFailures Class

Failures about DividedSurface.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresDividedSurfaceFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class DividedSurfaceFailures
Public NotInheritable Class DividedSurfaceFailures
public ref class DividedSurfaceFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DividedSurfaceFailures = class end

The BuiltInFailuresDividedSurfaceFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberDividedSurfaceCannotApplyDivideSettings Default Divide settings were not applied to Divided Surface. Please adjust grid spacing values manually.
Public propertyStatic memberDividedSurfaceCoincidingSplittingWorkplanes Coinciding splitting workplanes are encountered
Public propertyStatic memberDividedSurfaceCurveChainBelongsToMultipleBeltIntervals A chain formed by these curve elements defines a splitter belonging to multiple belt intervals and will be ignored
Public propertyStatic memberDividedSurfaceCurveChainBothUandV A chain formed by these curve elements is trying to be both U- and V- splitter
Public propertyStatic memberDividedSurfaceCurveChainDoesNotEngageUorV A chain formed by these curve elements does engage any gridlines on the face to be divided and will be ignored
Public propertyStatic memberDividedSurfaceCurveChainGeneralProblem The chain formed by these curve elements cannot be processed and will be ignored.
Public propertyStatic memberDividedSurfaceCurveChainIntersection A chain formed by these curve elements intersects other chain with the same grid orientation. Both chains will be ignored
Public propertyStatic memberDividedSurfaceCurveChainIsTooClosedToGridlines A chain formed by these curve elements defines a splitter which lies too close to gridlines and will be ignored
Public propertyStatic memberDividedSurfaceCurveChainMultipleSeqIntersWithDivLine The chain formed by these curve elements has multiple sequential intersections with a gridline and so the chain will be ignored
Public propertyStatic memberDividedSurfaceCurveChainNonSeqIntersWithDivLines The chain formed by these curve elements has multiple non-sequential intersections with the same gridline and will be ignored
Public propertyStatic memberDividedSurfaceCurveChainUnsortableBucket The chains formed by these curve elements cannot be ordered consistently in the their grid interval and will be ignored
Public propertyStatic memberDividedSurfaceCurveFromChainMultipleIntersWithDivLine A curve from the chain formed by these curve elements either intersects a gridline more than once or coincides with it and so the chain will be ignored
Public propertyStatic memberDividedSurfaceCurveLoopChainIntersectedByExtensions Curve elements forming a chain which is intersected by extensions of the chain ends cannot be used as splitters and are ignored.
Public propertyStatic memberDividedSurfaceCuttingSurfaceDoesNotCutMeshFace The surface-based splitter does not intersect a face to be divided and will be ignored
Public propertyStatic memberDividedSurfaceCuttingSurfaceGeneralProblem Cannot process a surface-based splitter
Public propertyStatic memberDividedSurfaceCuttingSurfaceMakesMultipleCuts The surface-based splitter intersects a face to be divided in multiple places and this case is not currently supported
Public propertyStatic memberDividedSurfaceDidNotRegenerateProperly Divided Surface gridlines could not be generated.
Public propertyStatic memberDividedSurfaceDiscardedSplittersWarning Not all intersecting references (levels, reference planes or lines) could be used to intersect the surface
Public propertyStatic memberDividedSurfaceIgnoresSplitters Revit cannot create a rectangular grid by intersecting the current selection of elements (levels, reference planes, or curves drawn on reference planes) with the surface. Make sure that curves do not form closed loops. It is helpful if curves start and end outside the surface, rather than inside it.
Public propertyStatic memberDividedSurfaceInvalidSpacing Constraints not satisfied, cannot generate gridlines.
Public propertyStatic memberDividedSurfaceLoopsOfSplittingCurves Curve elements forming a closed loop currently cannot be used as splitters and are ignored.
Public propertyStatic memberDividedSurfaceMultipleIntersBetweenOppositeVirtualGrids There are multiple intersections between splitting chain of virtual splitters defined by these elements and so one of the virtual splitters will be ignored
Public propertyStatic memberDividedSurfaceSelfIntersectingCurveLoopChain Curve elements forming a self-intersecting chain cannot be used as splitters and are ignored.
Public propertyStatic memberDividedSurfaceSingleCurveLoopsAsSplitters Curve elements forming a single curve loop cannot be used as splitters and are ignored.
Public propertyStatic memberDividedSurfaceSingleCurveMultipleIntersBetweenOppositeVirtualGrids There are curves in splitting chain of virtual splitters defined by these elements which intersect each other multiple times and so one of the virtual splitters will be ignored
Public propertyStatic memberDividedSurfaceSplitManagerProblem1dNonWPCurve Divided Surface cannot be split by a one dimensional curve without workplane
Public propertyStatic memberDividedSurfaceSplitManagerProblemClosedArcOrEllipse Divided Surface cannot be split by a closed arc or ellipse.
Public propertyStatic memberDividedSurfaceSplitRefInvisible Some of the splitting references of this Divided Surface are invisible in the current view.
Public propertyStatic memberDividedSurfaceSplittingCurveChainsBetweenMultipleNeighbors Curve elements which form chains connecting points shared by more than two curve elements are ignored.
Public propertyStatic memberDividedSurfaceSplittingCurvesWithMultipleNeighbors A point cannot coincide with end points of more than two curve elements. All curve elements adjacent to such a point are ignored.
Public propertyStatic memberDividedSurfaceZeroLengthSplittingCurve Curve element with zero length cannot be used as a splitter and ignored.
Public propertyStatic memberMeshTopologicalSortFailed Splitters and grids do not define a consistent rectangular mesh on the face.
Top
See Also