Revit 2025.3 API
Slab |
Note: This API is now obsolete.
Adds a point to the corresponding slab, roof or floor.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
[ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a future version of Revit. Use "AddPoint" instead. ")] public SlabShapeVertex DrawPoint( XYZ location )
<ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a future version of Revit. Use "AddPoint" instead. ")> Public Function DrawPoint ( location As XYZ ) As SlabShapeVertex
public: [ObsoleteAttribute(L"This method is deprecated in Revit 2025 and may be removed in a future version of Revit. Use "AddPoint" instead. ")] SlabShapeVertex^ DrawPoint( XYZ^ location )
[<ObsoleteAttribute("This method is deprecated in Revit 2025 and may be removed in a future version of Revit. Use "AddPoint" instead. ")>] member DrawPoint : location : XYZ -> SlabShapeVertex
Parameters
- location XYZ
- The location of the point.
Return Value
SlabShapeVertexThe newly created vertex.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the location is . |

If the input location is not on the top face of the slab, this function will return .
Drawing a point on boundary crease may increase the number of creases.
This method will regenerate the document even in manual regeneration mode.
See Also