SlabShapeEditor Class

SlabShapeEditor Class

An object used for Slab Shape Editing.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSlabShapeEditor

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class SlabShapeEditor : IDisposable
Public Class SlabShapeEditor
	Implements IDisposable
public ref class SlabShapeEditor : IDisposable
type SlabShapeEditor = 
    class
        interface IDisposable
    end

The SlabShapeEditor type exposes the following members.

Properties
 NameDescription
Public propertyIsEnabledIdentifies if the slab shape editing functionality is enabled.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertySlabShapeCreasesAll of the creases that can be edited.
Public propertySlabShapeVerticesAll of the vertices that can be edited.
Top
Methods
 NameDescription
Public methodAddPoint Add a point to the element.
Public methodAddPoints 
Public methodAddSplitLine Add a split line to the element.
Public methodCreateCreasesFromFoldingLines 
Public methodDeletePoint Delete a SlabShapeVertex from the element.
Public methodDisposeReleases all resources used by the SlabShapeEditor
Public methodDrawPointObsolete.
Adds a point to the corresponding slab, roof or floor.
Public methodDrawSplitLineObsolete.
Draws a split line on the corresponding slab, roof or floor.
Public methodEnableEnables the slab shape editing functionality.
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodModifySubElement(SlabShapeCrease, Double)Manipulates the crease on the corresponding slab, roof or floor.
Public methodModifySubElement(SlabShapeVertex, Double)Manipulates the vertex on the corresponding slab, roof or floor.
Public methodPickSupportPicks an element to support the slab. This method will define split lines and create constant bearing lines for the slab.
Public methodResetSlabShapeRemoves the modifications made during editing and resets the element geometry back to the unmodified state.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The SlabShapeEditor can be obtained from a slab object, such as a roof or floor.
See Also