Revit 2025.3 API
Slab |
Manipulates the crease on the corresponding slab, roof or floor.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void ModifySubElement( SlabShapeCrease crease, double offset )
Public Sub ModifySubElement ( crease As SlabShapeCrease, offset As Double )
public: void ModifySubElement( SlabShapeCrease^ crease, double offset )
member ModifySubElement : crease : SlabShapeCrease * offset : float -> unit
Parameters
- crease SlabShapeCrease
- The crease.
- offset Double
- The new value of the crease offset, which is the average of offsets of its ends.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the crease is . |
ArgumentException | Thrown when the crease is invalid. |
See Also