DetailElementOrderUtils Class

DetailElementOrderUtils Class

A utility class that arranges the draw order of the detail elements.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBDetailElementOrderUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class DetailElementOrderUtils
Public NotInheritable Class DetailElementOrderUtils
public ref class DetailElementOrderUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DetailElementOrderUtils = class end

The DetailElementOrderUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberAreDetailElements 
Public methodStatic memberBringForward(Document, View, ElementId) Moves the given detail instance one step closer to the front of all other detail instances in the view.
Public methodStatic memberBringForward(Document, View, ICollectionElementId) 
Public methodStatic memberBringToFront(Document, View, ElementId) Places the given detail instance in the front of all other detail instances in the view.
Public methodStatic memberBringToFront(Document, View, ICollectionElementId) 
Public methodStatic memberGetDrawOrderForDetails 
Public methodStatic memberIsDetailElement Indicates if the element is a detail element that participates in detail draw ordering in the view.
Public methodStatic memberSendBackward(Document, View, ElementId) Moves the given detail instance one step closer to the back of all other detail instances in the view.
Public methodStatic memberSendBackward(Document, View, ICollectionElementId) 
Public methodStatic memberSendToBack(Document, View, ElementId) Places the given detail instance behind all detail instances in the view.
Public methodStatic memberSendToBack(Document, View, ICollectionElementId) 
Top
See Also