Revit 2025.3 API
Detail |
Places the given detail instance in the front of all other detail instances in the view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static void BringToFront( Document document, View view, ElementId detailElementId )
Public Shared Sub BringToFront ( document As Document, view As View, detailElementId As ElementId )
public: static void BringToFront( Document^ document, View^ view, ElementId^ detailElementId )
static member BringToFront : document : Document * view : View * detailElementId : ElementId -> unit
Parameters

Exception | Condition |
---|---|
ArgumentException | The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- The element detailElementId is not a detail or it does not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes. |
ArgumentNullException | A non-optional argument was null |
See Also