Profile Class

Profile Class

A geometric profile consisting of a loop of curves.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBGeometryObject
      Autodesk.Revit.DBProfile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class Profile : GeometryObject
Public Class Profile
	Inherits GeometryObject
public ref class Profile : public GeometryObject
type Profile = 
    class
        inherit GeometryObject
    end

The Profile type exposes the following members.

Properties
 NameDescription
Public propertyCurvesRetrieve the curves that make up the boundary of the profile.
Public propertyFilledGet or set whether the profile is filled.
Public propertyGraphicsStyleIdThe ElementId of the GeometryObject's GraphicsStyle
(Inherited from GeometryObject)
Public propertyIdA unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
(Inherited from GeometryObject)
Public propertyIsElementGeometryIndicates whether this geometry is obtained directly from an Element.
(Inherited from GeometryObject)
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyTransformedTransforms this profile and returns the result.
Public propertyVisibilityThe visibility.
(Inherited from GeometryObject)
Top
Methods
 NameDescription
Public methodCloneReturns a copy of this profile.
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEquals Determines whether the specified Object is equal to the current Object.
(Inherited from GeometryObject)
Public methodGetHashCode Gets the integer value of the geometry object as hash code
(Inherited from GeometryObject)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
The profile may be filled.
See Also