Profile Class

Profile Class

A geometric profile consisting of a loop of curves.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBGeometryObject
      Autodesk.Revit.DBProfile

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class Profile : GeometryObject
Public Class Profile
	Inherits GeometryObject
public ref class Profile : public GeometryObject
type Profile = 
    class
        inherit GeometryObject
    end

The Profile type exposes the following members.

Properties
 NameDescription
Public propertyCurvesRetrieve the curves that make up the boundary of the profile.
Public propertyFilledGet or set whether the profile is filled.
Public propertyTransformedTransforms this profile and returns the result.
Top
Methods
 NameDescription
Public methodCloneReturns a copy of this profile.
Top
Remarks
The profile may be filled.
See Also