PrintParameters.PaperSize Property

PrintParametersPaperSize Property

The page size.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public PaperSize PaperSize { get; set; }
Public Property PaperSize As PaperSize
	Get
	Set
public:
property PaperSize^ PaperSize {
	PaperSize^ get ();
	void set (PaperSize^ value);
}
member PaperSize : PaperSize with get, set

Property Value

PaperSize
Exceptions
ExceptionCondition
ArgumentNullException Thrown when the input argument is .
ArgumentException Thrown when the input argument is invalid for current printer.
Remarks
User can select the candidate via PaperSizes and then set the Page source of the Print Setting.
See Also