PrintParameters Class

PrintParameters Class

An object that contains settings used for printing the document.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBPrintParameters

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class PrintParameters : APIObject
Public Class PrintParameters
	Inherits APIObject
public ref class PrintParameters : public APIObject
type PrintParameters = 
    class
        inherit APIObject
    end

The PrintParameters type exposes the following members.

Properties
 NameDescription
Public propertyColorDepth The color depth type.
Public propertyHiddenLineViews The hidden line views type.
Public propertyHideCropBoundaries Indicates whether to hide crop boundaries when printing.
Public propertyHideReforWorkPlanes Indicates whether to hide reference/work planes when printing.
Public propertyHideScopeBoxes Indicates whether to hide scope boxes when printing.
Public propertyHideUnreferencedViewTags Indicates whether to hide unreferenced view tags when printing.
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyMarginType The print margin type.
Public propertyMaskCoincidentLines Indicates whether to mask coincident lines when printing.
Public propertyOriginOffsetX The User defined X value of offset from left bottom corner. Unit is feet.
Public propertyOriginOffsetY The User defined Y value of offset from left bottom corner. Unit is feet.
Public propertyPageOrientation The Page Orientation of the Print Setting.
Public propertyPaperPlacement The paper placement type.
Public propertyPaperSize The page size.
Public propertyPaperSource The page source.
Public propertyRasterQuality The raster quality type.
Public propertyReplaceHalftoneWithThinLines Indicates whether to replace halftone with thin lines when printing.
Public propertyUserDefinedMarginXObsolete.
The User defined X value of offset from left bottom corner. Unit is inch.
Public propertyUserDefinedMarginYObsolete.
The User defined Y value of offset from left bottom corner. Unit is inch.
Public propertyViewLinksinBlue Indicates whether to view links in blue when printing.
Public propertyZoom The zoom value to a percentage of the original size.
Public propertyZoomType The zoom type.
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also