UpdaterInfo Class

UpdaterInfo Class

Information of an updater, such as: Name, AdditionalInformation, name of the application that owns the updater, etc.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBUpdaterInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class UpdaterInfo : IDisposable
Public Class UpdaterInfo
	Implements IDisposable
public ref class UpdaterInfo : IDisposable
type UpdaterInfo = 
    class
        interface IDisposable
    end

The UpdaterInfo type exposes the following members.

Properties
 NameDescription
Public propertyAdditionalInformation Additional information about the updater.
Public propertyApplicationName Name of the application that owns the updater.
Public propertyIsOptional Whether the updater is optional or not.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyUpdaterName Name of the updater.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the UpdaterInfo
Top
See Also