FaceArray Class

FaceArray Class

An array that contains faces.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBFaceArray

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FaceArray : APIObject, IEnumerable
Public Class FaceArray
	Inherits APIObject
	Implements IEnumerable
public ref class FaceArray : public APIObject, 
	IEnumerable
type FaceArray = 
    class
        inherit APIObject
        interface IEnumerable
    end

The FaceArray type exposes the following members.

Constructors
 NameDescription
Public methodFaceArrayInitializes a new instance of the FaceArray class
Top
Properties
 NameDescription
Public propertyIsEmptyTest to see if the array is empty.
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyItemGets or sets a face at a specified index within the array.
Public propertySizeReturns the number of faces that are in the array.
Top
Methods
 NameDescription
Public methodAppendAdd the face to the end of the array.
Public methodClearRemoves every face from the array, rendering it empty.
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodForwardIteratorRetrieve a forward moving iterator to the array.
Public methodGetEnumeratorRetrieve a forward moving iterator to the array.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodInsertInsert the specified face into the array.
Public methodReverseIteratorRetrieve a backward moving iterator to the array.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also