CompoundStructure.SetNumberOfShellLayers Method

CompoundStructureSetNumberOfShellLayers Method

Sets the number of interior or exterior shell layers.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void SetNumberOfShellLayers(
	ShellLayerType shellLayerType,
	int numLayers
)
Public Sub SetNumberOfShellLayers ( 
	shellLayerType As ShellLayerType,
	numLayers As Integer
)
public:
void SetNumberOfShellLayers(
	ShellLayerType shellLayerType, 
	int numLayers
)
member SetNumberOfShellLayers : 
        shellLayerType : ShellLayerType * 
        numLayers : int -> unit 

Parameters

shellLayerType  ShellLayerType
If ShellLayerType.Exterior set the number of exterior shell layers (or top shell layers for a roof, floor, or ceiling type). If ShellLayerType.Interior set the number of interior shell layers (or bottom shell layers for a roof, floor, or ceiling type).
numLayers  Int32
The number of layers to be in the specified shell.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException Number of shell layers is negative. -or- A value passed for an enumeration argument is not a member of that enumeration
ArgumentsInconsistentException Too many shell layers: there must be at least one core layer.
Remarks
There must be at least one core layer, i.e. one layer which is not a shell layer.
See Also