ExternalResourceServerExtensions Class

ExternalResourceServerExtensions Class

An object that contains overrides for external resource-specific methods.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBExternalResourceServerExtensions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ExternalResourceServerExtensions : IDisposable
Public Class ExternalResourceServerExtensions
	Implements IDisposable
public ref class ExternalResourceServerExtensions : IDisposable
type ExternalResourceServerExtensions = 
    class
        interface IDisposable
    end

The ExternalResourceServerExtensions type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the ExternalResourceServerExtensions
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetCADLinkOperations Gets the specific methods supported by external resource CAD Links.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetRevitLinkOperations Gets the specific methods supported by the external resource of Revit Links.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks

This class permits assignment of some specific operations related to a type of external resource, such as what to do when "Open (and Unload)" happens, or when "Shared Coordinates update" happens for Revit or CAD links.

There is no feedback to the UI server for ExternalResourceServerExtensions. Revit will use standard, common message dialogs to handle any error conditions.

See Also