Revit 2025.3 API
Assembly |
Transfers the assembly views owned by a source assembly instance to a target sibling assembly instance of the same assembly type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static void AcquireAssemblyViews( Document document, ElementId sourceAssemblyInstanceId, ElementId targetAssemblyInstanceId )
Public Shared Sub AcquireAssemblyViews ( document As Document, sourceAssemblyInstanceId As ElementId, targetAssemblyInstanceId As ElementId )
public: static void AcquireAssemblyViews( Document^ document, ElementId^ sourceAssemblyInstanceId, ElementId^ targetAssemblyInstanceId )
static member AcquireAssemblyViews : document : Document * sourceAssemblyInstanceId : ElementId * targetAssemblyInstanceId : ElementId -> unit
Parameters

Exception | Condition |
---|---|
ArgumentException | sourceAssemblyInstanceId is not an AssemblyInstance with assembly views. -or- targetAssemblyInstanceId is not an AssemblyInstance. -or- sourceAssemblyInstanceId and targetAssemblyInstanceId are not AssemblyInstances from the same assembly type. |
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |
See Also