AssemblyViewUtils Class

AssemblyViewUtils Class

Utilities that provide capabilities related to assembly view creation and validation.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAssemblyViewUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class AssemblyViewUtils
Public NotInheritable Class AssemblyViewUtils
public ref class AssemblyViewUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AssemblyViewUtils = class end

The AssemblyViewUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberAcquireAssemblyViews Transfers the assembly views owned by a source assembly instance to a target sibling assembly instance of the same assembly type.
Public methodStatic memberCreate3DOrthographic(Document, ElementId) Creates a new orthographic 3D assembly view for the assembly instance.
Public methodStatic memberCreate3DOrthographic(Document, ElementId, ElementId, Boolean) Creates a new orthographic 3D assembly view for the assembly instance. The view will have the same orientation as the Default 3D view. The document must be regenerated before using the 3D view.
Public methodStatic memberCreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation) Creates a new detail section assembly view for the assembly instance.
Public methodStatic memberCreateDetailSection(Document, ElementId, AssemblyDetailViewOrientation, ElementId, Boolean) Creates a new detail section assembly view for the assembly instance.
Public methodStatic memberCreateMaterialTakeoff(Document, ElementId) Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
Public methodStatic memberCreateMaterialTakeoff(Document, ElementId, ElementId, Boolean) Creates a new material takeoff multicategory schedule assembly view for the assembly instance.
Public methodStatic memberCreatePartList(Document, ElementId) Creates a new part list multicategory schedule assembly view for the assembly instance.
Public methodStatic memberCreatePartList(Document, ElementId, ElementId, Boolean) Creates a new part list multicategory schedule assembly view for the assembly instance.
Public methodStatic memberCreateSheet Creates a new sheet assembly view for the assembly instance.
Public methodStatic memberCreateSingleCategorySchedule(Document, ElementId, ElementId) Creates a new single-category schedule assembly view for the assembly instance.
Public methodStatic memberCreateSingleCategorySchedule(Document, ElementId, ElementId, ElementId, Boolean) Creates a new single-category schedule assembly view for the assembly instance.
Top
See Also