Revit 2025.3 API
Assembly |
Creates a new orthographic 3D assembly view for the assembly instance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static View3D Create3DOrthographic( Document document, ElementId assemblyInstanceId )
Public Shared Function Create3DOrthographic ( document As Document, assemblyInstanceId As ElementId ) As View3D
public: static View3D^ Create3DOrthographic( Document^ document, ElementId^ assemblyInstanceId )
static member Create3DOrthographic : document : Document * assemblyInstanceId : ElementId -> View3D
Parameters
- document Document
- The document to which the view will be added.
- assemblyInstanceId ElementId
- Id of the assembly instance that owns the new view.
Return Value
View3DA new orthographic 3D assembly view.

Exception | Condition |
---|---|
ArgumentException | assemblyInstanceId is not an AssemblyInstance. |
ArgumentNullException | A non-optional argument was null |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |

The view will have the same orientation as the Default 3D view.
The document must be regenerated before using the 3D view.
See Also