Revit 2025.3 API
Assembly |
Creates a new detail section assembly view for the assembly instance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static ViewSection CreateDetailSection( Document document, ElementId assemblyInstanceId, AssemblyDetailViewOrientation direction, ElementId viewTemplateId, bool isAssigned )
Public Shared Function CreateDetailSection ( document As Document, assemblyInstanceId As ElementId, direction As AssemblyDetailViewOrientation, viewTemplateId As ElementId, isAssigned As Boolean ) As ViewSection
public: static ViewSection^ CreateDetailSection( Document^ document, ElementId^ assemblyInstanceId, AssemblyDetailViewOrientation direction, ElementId^ viewTemplateId, bool isAssigned )
static member CreateDetailSection : document : Document * assemblyInstanceId : ElementId * direction : AssemblyDetailViewOrientation * viewTemplateId : ElementId * isAssigned : bool -> ViewSection
Parameters
- document Document
- The document to which the view will be added.
- assemblyInstanceId ElementId
- Id of the assembly instance that owns the new view.
- direction AssemblyDetailViewOrientation
- The direction for the new view.
- viewTemplateId ElementId
- Id of the view template that is used to create the view; if invalidElementId, the view will be created with the default settings.
- isAssigned Boolean
- If true, the template will be assigned; if false, the template will be applied.
Return Value
ViewSectionA new detail section assembly view.

Exception | Condition |
---|---|
ArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- viewTemplateId is not a correct view template for the geom view. |
ArgumentNullException | A non-optional argument was null |
ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |
ModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
ModificationOutsideTransactionException | The document has no open transaction. |

The detail section will cut through the center of the assembly instance's outline.
The document must be regenerated before using the detail section.
See Also