Revit 2025.3 API
DocumentGet |
Gets the subelement referenced by a unique id string.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Subelement GetSubelement( string uniqueId )
Public Function GetSubelement ( uniqueId As String ) As Subelement
public: Subelement^ GetSubelement( String^ uniqueId )
member GetSubelement : uniqueId : string -> Subelement
Parameters
- uniqueId String
-
The unique id that identifies element or subelement.
- UniqueId
Return Value
SubelementThe subelement referenced by the input argument.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |

will be returned if the input id string doesn't reference to a valid element or subelement.
See Also