Revit 2025.3 API
Adaptive |
Verifies if a FamilyInstance is an Adaptive Component Instance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static bool IsAdaptiveComponentInstance( FamilyInstance famInst )
Public Shared Function IsAdaptiveComponentInstance ( famInst As FamilyInstance ) As Boolean
public: static bool IsAdaptiveComponentInstance( FamilyInstance^ famInst )
static member IsAdaptiveComponentInstance : famInst : FamilyInstance -> bool
Parameters
- famInst FamilyInstance
- The FamilyInstance
Return Value
BooleanTrue if the FamilyInstance has an Adaptive Component Instances.

Exception | Condition |
---|---|
ArgumentNullException | A non-optional argument was null |
See Also