ParameterFilterRuleFactory.CreateLessRule(ElementId, ElementId) Method

ParameterFilterRuleFactoryCreateLessRule(ElementId, ElementId) Method

Creates a filter rule that determines whether ElementId values from the document are less than a certain value.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static FilterRule CreateLessRule(
	ElementId parameter,
	ElementId value
)
Public Shared Function CreateLessRule ( 
	parameter As ElementId,
	value As ElementId
) As FilterRule
public:
static FilterRule^ CreateLessRule(
	ElementId^ parameter, 
	ElementId^ value
)
static member CreateLessRule : 
        parameter : ElementId * 
        value : ElementId -> FilterRule 

Parameters

parameter  ElementId
An ElementId-typed parameter used to get values from the document for a given element.
value  ElementId
The user-supplied value against which values from the document will be compared.

Return Value

FilterRule
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was null
See Also