ElementIdSetFilter Class

ElementIdSetFilter Class

A filter wrapping a set of elements.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementQuickFilter
      Autodesk.Revit.DBElementIdSetFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ElementIdSetFilter : ElementQuickFilter
Public Class ElementIdSetFilter
	Inherits ElementQuickFilter
public ref class ElementIdSetFilter : public ElementQuickFilter
type ElementIdSetFilter = 
    class
        inherit ElementQuickFilter
    end

The ElementIdSetFilter type exposes the following members.

Constructors
 NameDescription
Public methodElementIdSetFilterInitializes a new instance of the ElementIdSetFilter class
Top
Properties
 NameDescription
Top
Methods
 NameDescription
Public methodGetIdsToInclude Returns the ids of this filter.
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also