Revit 2025.3 API
Line |
A structure that has access to the pen properties of lines/curves
that are currently being drawn/exported via an export context
during a custom export process.

SystemObject
Autodesk.Revit.DBLineProperties
Autodesk.Revit.DBLineProperties
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The LineProperties type exposes the following members.

Name | Description | |
---|---|---|
![]() | Color | The current color used when drawing lines/curves. |
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |
![]() | LineWidth | The current width (thickness) of the pen stroke when drawing lines/curves. |
![]() | PatternId | Id of the current Line pattern element used when drawing lines/curves. |
![]() | Transparency | The current transparency level to be applied to the current color. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the LineProperties |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |

For more about using properties of this class refer to the interface
[!:Autodesk::Revit::DB::IModelExportContext] and its methods
which handle geometric objects such as [!:Autodesk::Revit::DB::IModelExportContext::OnCurve],
[!:Autodesk::Revit::DB::IModelExportContext::OnLineSegment], etc.
LineProperties are available as a read-only property on the respective output nodes,
i.e. [!:Autodesk::Revit::DB::CurveNode], [!:Autodesk::Revit::DB::LineSegment], etc.
See Also