FilteredWorksetIterator Class

FilteredWorksetIterator Class

An iterator to a set of worksets filtered by the settings of a FilteredWorksetCollector.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFilteredWorksetIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FilteredWorksetIterator : IEnumerator<Workset>
Public Class FilteredWorksetIterator
	Implements IEnumerator(Of Workset)
public ref class FilteredWorksetIterator : IEnumerator<Workset^>
type FilteredWorksetIterator = 
    class
        interface IEnumerator<Workset>
    end

The FilteredWorksetIterator type exposes the following members.

Properties
 NameDescription
Public propertyCurrentGets the item at the current position of the iterator.
Protected propertyCurrentObject 
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the FilteredWorksetIterator
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetCurrent The current workset found by the iterator.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsDone Identifies if the iteration has completed.
Public methodMoveNext Increments the iterator to the next workset passing the filter.
Public methodReset Resets the iterator to the beginning.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also