Revit 2025.3 API
Adaptive |
Gets Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static IList<ElementId> GetInstanceShapeHandlePointElementRefIds( FamilyInstance famInst )
Public Shared Function GetInstanceShapeHandlePointElementRefIds ( famInst As FamilyInstance ) As IList(Of ElementId)
public: static IList<ElementId^>^ GetInstanceShapeHandlePointElementRefIds( FamilyInstance^ famInst )
static member GetInstanceShapeHandlePointElementRefIds : famInst : FamilyInstance -> IList<ElementId>
Parameters
- famInst FamilyInstance
- The FamilyInstance
Return Value
IListElementIdThe Shape Handle Adaptive Point Element Ref ids to which the instance geometry adapts.

Exception | Condition |
---|---|
ArgumentException | The FamilyInstance famInst is not an Adaptive Family Instance. -or- The FamilyInstance famInst does not have an Adaptive Family Symbol. |
ArgumentNullException | A non-optional argument was null |
InvalidOperationException | This operation failed. |

The output contains shape handle point ref ids.
If there are no shape handle points defined in the Family then the output
is empty.
See Also