Revit 2025.3 API
Family |
Provides access to the integer number of the given family parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public int? AsInteger( FamilyParameter familyParameter )
Public Function AsInteger ( familyParameter As FamilyParameter ) As Integer?
public: Nullable<int> AsInteger( FamilyParameter^ familyParameter )
member AsInteger : familyParameter : FamilyParameter -> Nullable<int>
Parameters
- familyParameter FamilyParameter
Return Value
NullableInt32The integer value contained in the parameter. Returns if the storage type of the input argument is not integer type or this parameter has no value.

Exception | Condition |
---|---|
ArgumentNullException | Thrown when the input argument-"familyParameter"-is . |
ArgumentException | Thrown if the input argument-"familyParameter"-is invalid, |
See Also