Revit 2025.3 API
Appearance |
Creates a new AppearanceAssetElement from an existing rendering asset.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static AppearanceAssetElement Create( Document document, string name, Asset asset )
Public Shared Function Create ( document As Document, name As String, asset As Asset ) As AppearanceAssetElement
public: static AppearanceAssetElement^ Create( Document^ document, String^ name, Asset^ asset )
static member Create : document : Document * name : string * asset : Asset -> AppearanceAssetElement
Parameters
- document Document
- The document in which to create the AppearanceAssetElement.
- name String
- The name of the AppearanceAssetElement.
- asset Asset
- The rendering asset of the element.
Return Value
AppearanceAssetElementThe new AppearanceAssetElement.

Exception | Condition |
---|---|
ArgumentException | name is an empty string. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- The given value for name is already in use as an appearance asset name. |
ArgumentNullException | A non-optional argument was null |
See Also