AXMImportOptions Class

AXMImportOptions Class

The import options used to import AXM format files.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBaseImportOptions
    Autodesk.Revit.DBAXMImportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class AXMImportOptions : BaseImportOptions
Public Class AXMImportOptions
	Inherits BaseImportOptions
public ref class AXMImportOptions : public BaseImportOptions
type AXMImportOptions = 
    class
        inherit BaseImportOptions
    end

The AXMImportOptions type exposes the following members.

Constructors
 NameDescription
Public methodAXMImportOptions Constructs a new instance of AXMImportOptions with default values of all properties.
Public methodAXMImportOptions(AXMImportOptions) Constructs a new instance of AXMImportOptions as a copy of the provided import options.
Top
Properties
 NameDescription
Public propertyImportLevels Indicate if levels are to be imported. False by default.
Top
Methods
 NameDescription
Top
See Also