FBXExportOptions Class

FBXExportOptions Class

3D-Studio Max (FBX) Export options.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFBXExportOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FBXExportOptions
Public Class FBXExportOptions
public ref class FBXExportOptions
type FBXExportOptions = class end

The FBXExportOptions type exposes the following members.

Constructors
 NameDescription
Public methodFBXExportOptionsDefault constructor. Sets all options to their default values.
Top
Properties
 NameDescription
Public propertyLevelsOfDetailValueThe value of the levels of detail.
Public propertyStopOnErrorWhether export process should stop when a view fails to export.
Public propertyUseLevelsOfDetailTrue to use levels of detail, false otherwise.
Public propertyWithoutBoundaryEdgesTrue to export without boundary edges, false otherwise.
Top
Methods
 NameDescription
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also