MEPAnalyticalSegment Class

MEPAnalyticalSegment Class

Represents an analytical segment of the MEP analytical model.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DB.AnalysisMEPAnalyticalSegment

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
public class MEPAnalyticalSegment : IDisposable
Public Class MEPAnalyticalSegment
	Implements IDisposable
public ref class MEPAnalyticalSegment : IDisposable
type MEPAnalyticalSegment = 
    class
        interface IDisposable
    end

The MEPAnalyticalSegment type exposes the following members.

Properties
 NameDescription
Public propertyArea The area of the segment profile.
Public propertyDemandFlow The designed flow value, in ft^3/s.
Public propertyDomainType The connector domain type of this segment.
Public propertyEndNode The id of the end analytical node.
Public propertyId The identity of this segment.
Public propertyInnerDiameter The inner diameter of this segment, in ft. For rectangular or oval profile, this may be the hydraulic diameter.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyOverrideType The override type of analytical segment pressure loss calculation.
Public propertyRevitElementId The id of the owning Revit element.
Public propertyRoughness The roughness of this segment, in ft.
Public propertySegmentType The analytical segment type.
Public propertyStartNode The id of the start analytical node.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the MEPAnalyticalSegment
Public methodGetFlowCharacteristics Gets all flow characteristics of the segment.
Public methodGetFlowConvergenceCharacteristic Gets the flow convergence characteristic of the segment.
Public methodGetFlowTransitionCharacteristic Gets the flow transition characteristic of the segment.
Public methodGetLossCoefficientOverride Gets the overridden value of loss coefficient, dimensionless.
Public methodGetNetworkSegmentId Gets the NetworkSegmentId.
Public methodGetPressureDropOverride Gets the overidden value of pressuer drop, in kg/(ft*s^2).
Public methodIsSegmentOverridable Verifies if the segment can be overridden (e.g., the pressure drop of the pump and curve segments are calculated from the network and cannot be overridden).
Public methodSetLossCoefficientOverride Sets the overridden value of loss coefficient.
Public methodSetOverrideType Sets the override type of pressure loss calculation.
Public methodSetPressureDropOverride Sets the overridden value of pressure drop.
Top
See Also