Revit 2026 API
Family |
This object represents data corresponding to the placement references in a
certain types of Family Instances (see examples listed below).

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 26.0.4.0 (26.0.4.0)
Syntax
The FamilyPointPlacementReference type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsReadOnly | Identifies if the object is read-only or modifiable. (Inherited from APIObject) |
![]() | Location | The location of the point. |
![]() | Name | The name of the corresponding reference point in the Family document. |
![]() | PointReference | The reference on which the point depends on. |

Name | Description | |
---|---|---|
![]() | Dispose | Causes the object to release immediately any resources it may be utilizing. (Inherited from APIObject) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |

Examples of FamilyInstance objects that contain placement references are Panels
and Flexible Components.
See Also