GroupTable Class

GroupTable Class

Group tables store the list of groups in a Rhino document.
Inheritance Hierarchy
SystemObject
  Rhino.DocObjects.TablesGroupTable

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class GroupTable
Public NotInheritable Class GroupTable

The GroupTable type exposes the following members.

Properties
  NameDescription
Public propertyComponentType (Overrides CommonComponentTableTComponentType.)
Public propertyCount
Number of groups in the group table.


In Rhino for Windows 6.8, this member is inherited from CommonComponentTableTCount.
Public propertyDocument
Document that owns this group table.


In Rhino for Windows 6.8, this member is inherited from RhinoDocCommonTableTDocument.
Top
Methods
  NameDescription
Public methodAdd
Adds a new empty group to the group table.
Public methodCode exampleAdd(IEnumerableGuid)
Adds a new group to the group table with a set of objects.
Public methodAdd(String)
Adds a new empty group to the group table.
Public methodAdd(String, IEnumerableGuid)
Adds a new group to the group table with a set of objects.
Public methodAddToGroup(Int32, IEnumerableGuid)
Adds a list of objects to an existing group.
Public methodAddToGroup(Int32, Guid)
Adds an object to an existing group.
Public methodChangeGroupName
Public methodDelete(Int32)
Deletes a group from this table.

Deleted groups are kept in the runtime group table so that undo will work with groups. Call IsDeleted() to determine if a group is deleted.

Public methodDelete(Group) (Overrides CommonComponentTableTDelete(T).)
Public methodFind(String)
Finds a group with a given name.
Public methodFind(String, Boolean)
Finds a group with a given name.
Public methodFindIndex
Retrieves a Group object based on Index. This seach type of search is discouraged. We are moving towards using only IDs for all tables.
Public methodFindName
Finds a Linetype given its name. Returns the instance, rather than the index.
Public methodFindNameHash
Finds a Linetype given its name hash.
Public methodGroupMembers
Gets an array of all of the objects in a group.
Public methodGroupName
Public methodGroupNames
Public methodGroupObjectCount
Public methodHide
Public methodIsDeleted
Public methodLock
Public methodShow
Public methodUndelete
Public methodUnlock
Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also