StringTable Class

StringTable Class

Collection of document user data strings
Inheritance Hierarchy
SystemObject
  Rhino.DocObjects.TablesStringTable

Namespace:  Rhino.DocObjects.Tables
Assembly:  RhinoCommon (in RhinoCommon.dll)
Syntax
public sealed class StringTable
Public NotInheritable Class StringTable

The StringTable type exposes the following members.

Properties
  NameDescription
Public propertyCount
The number of user data strings in the current document.
Public propertyDocument
Document that owns this object table.
Public propertyDocumentDataCount
Public propertyDocumentUserTextCount
Top
Methods
  NameDescription
Public methodDelete(String)
Public methodDelete(String, String)
Removes user data strings from the document.
Public methodGetEntryNames
Return list of all entry names for a given section of user data strings in the document.
Public methodGetKey
Public methodGetSectionNames
Returns a list of all the section names for user data strings in the document.

By default a section name is a key that is prefixed with a string separated by a backslash.

Public methodGetValue(Int32)
Public methodGetValue(String)
Public methodGetValue(String, String)
Gets a user data string from the document.
Public methodSetString(String, String)
Adds or sets a user data string to the document.
Public methodSetString(String, String, String)
Adds or sets a user data string to the document.
Top
Version Information

Rhino for Mac

Supported in: 5.4

Rhino for Windows

Supported in: 6.8
See Also