Creates a new topography surface element and adds it to the document.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2014
Syntax
C# |
---|
[ObsoleteAttribute("This method is deprecated in Revit 2024 with the introduction of the new Toposolid elements. It is recommended that Toposolid elements should be used in place of TopographySurface elements.")]
public static TopographySurface Create(
Document document,
IList<XYZ> points
) |
Visual Basic |
---|
<ObsoleteAttribute("This method is deprecated in Revit 2024 with the introduction of the new Toposolid elements. It is recommended that Toposolid elements should be used in place of TopographySurface elements.")> _
Public Shared Function Create ( _
document As Document, _
points As IList(Of XYZ) _
) As TopographySurface |
Visual C++ |
---|
[ObsoleteAttribute(L"This method is deprecated in Revit 2024 with the introduction of the new Toposolid elements. It is recommended that Toposolid elements should be used in place of TopographySurface elements.")]
public:
static TopographySurface^ Create(
Document^ document,
IList<XYZ^>^ points
) |
Parameters
- document
- Type: Autodesk.Revit.DB..::..Document
The document to be modified.
- points
- Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
A collection of points.
The points represent an enclosed area in the XY plane.
There can be only one point in the same XY location.
Return Value
The new topography surface.
Remarks
Exceptions
See Also