Identify whether the points can construct a valid region for a topography surface.
Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:
2014
Syntax
C# |
---|
public static bool IsValidRegion(
IList<XYZ> points
) |
Visual Basic |
---|
Public Shared Function IsValidRegion ( _
points As IList(Of XYZ) _
) As Boolean |
Visual C++ |
---|
public:
static bool IsValidRegion(
IList<XYZ^>^ points
) |
Parameters
- points
- Type: System.Collections.Generic..::..IList<(Of <(<'XYZ>)>)>
The points set to be checked.
Return Value
True if the size of points is not less than 3 and the points are not collinear after projecting to XY plane, that is, ignoring the elevation.
Exceptions
See Also