Line.CreateUnbound Method

LineCreateUnbound Method

Creates a new instance of an unbound linear curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static Line CreateUnbound(
	XYZ origin,
	XYZ direction
)
Public Shared Function CreateUnbound ( 
	origin As XYZ,
	direction As XYZ
) As Line
public:
static Line^ CreateUnbound(
	XYZ^ origin, 
	XYZ^ direction
)
static member CreateUnbound : 
        origin : XYZ * 
        direction : XYZ -> Line 

Parameters

origin  XYZ
The origin of the unbound line.
direction  XYZ
The direction of the unbound line.

Return Value

Line
The new unbound line.
Exceptions
ExceptionCondition
ArgumentNullException A non-optional argument was NULL
ArgumentOutOfRangeException direction has zero length.
ArgumentsInconsistentException Vector and origin cannot form a proper unbound line.
See Also