ExclusionFilter Class

ExclusionFilter Class

A filter used to exclude a set of elements automatically.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBElementFilter
    Autodesk.Revit.DBElementQuickFilter
      Autodesk.Revit.DBExclusionFilter

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class ExclusionFilter : ElementQuickFilter
Public Class ExclusionFilter
	Inherits ElementQuickFilter
public ref class ExclusionFilter : public ElementQuickFilter
type ExclusionFilter = 
    class
        inherit ElementQuickFilter
    end

The ExclusionFilter type exposes the following members.

Constructors
 NameDescription
Public methodExclusionFilterInitializes a new instance of the ExclusionFilter class
Top
Properties
 NameDescription
Top
Methods
 NameDescription
Public methodGetIdsToExclude Returns the ids to be excluded by this filter.
Top
Remarks
This filter is a quick filter. Quick filters operate only on the ElementRecord, a low-memory class which has a limited interface to read element properties. Elements which are rejected by a quick filter will not be expanded in memory.
See Also