City Class

City Class

An object that contains geographical location information for a known city.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBCity

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class City : APIObject
Public Class City
	Inherits APIObject
public ref class City : public APIObject
type City = 
    class
        inherit APIObject
    end

The City type exposes the following members.

Properties
 NameDescription
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyLatitudeLatitude of the city
Public propertyLongitudeLongitude of the city
Public propertyNameThe name of the city
Public propertyTimeZoneTime-zone in which the city resides
Public propertyWeatherStationAn identifier for the nearest weather station
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
This object contains longitude, latitude, time zone information for a city already known by Revit. Currently Revit does not the ability to add cities to the existing list. The list of known cities can be retrieved using the Cities property on the application object.
See Also