Revit 2025.3 API
Instance |
An output node that represents an instance of a geometry. It can be an instance of FamilyInstance, or it can be and instance of a part of symbol's geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The InstanceNode type exposes the following members.

Name | Description | |
---|---|---|

Name | Description | |
---|---|---|
![]() | GetSymbolGeometryId | Gets the SymbolGeometryId associated with the node. |

See also: [!:Autodesk::Revit::DB::IExportContext::OnInstanceBegin].
The SymbolGeometryId. contains the data for comparing if two InstanceNode points to the same geometry.
See Also