Revit 2025.3 API
Instance |
An output node that represents an instance of a geometry. It can be an instance of FamilyInstance, or it can be and instance of a part of symbol's geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The InstanceNode type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject |
Specifies whether the .NET object represents a valid Revit entity.
(Inherited from RenderNode) |
![]() | NodeName |
A readable name of the output node.
(Inherited from RenderNode) |

Name | Description | |
---|---|---|
![]() | Dispose | (Inherited from RenderNode) |
![]() | Equals | Determines whether the specified object is equal to the current object. (Inherited from Object) |
![]() | GetHashCode | Serves as the default hash function. (Inherited from Object) |
![]() | GetSymbolGeometryId | Gets the SymbolGeometryId associated with the node. |
![]() | GetTransform |
A transformation matrix associated with the node.
(Inherited from GroupNode) |
![]() | GetType | Gets the Type of the current instance. (Inherited from Object) |
![]() | ToString | Returns a string that represents the current object. (Inherited from Object) |

See also: [!:Autodesk::Revit::DB::IExportContext::OnInstanceBegin].
The SymbolGeometryId. contains the data for comparing if two InstanceNode points to the same geometry.
See Also