HasValueFilterRule Class

HasValueFilterRule Class

Tests whether an element's parameter has a value.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFilterRule
    Autodesk.Revit.DBParameterValuePresenceRule
      Autodesk.Revit.DBHasValueFilterRule

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class HasValueFilterRule : ParameterValuePresenceRule
Public Class HasValueFilterRule
	Inherits ParameterValuePresenceRule
public ref class HasValueFilterRule : public ParameterValuePresenceRule
type HasValueFilterRule = 
    class
        inherit ParameterValuePresenceRule
    end

The HasValueFilterRule type exposes the following members.

Constructors
 NameDescription
Public methodHasValueFilterRule constructs an instance of HasValueFilterRule.
Top
Properties
 NameDescription
Top
Methods
 NameDescription
Top
See Also