BuiltInFailures.MEPFabricationFailures Class

BuiltInFailuresMEPFabricationFailures Class

Failures about MEP fabrication.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresMEPFabricationFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class MEPFabricationFailures
Public NotInheritable Class MEPFabricationFailures
public ref class MEPFabricationFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MEPFabricationFailures = class end

The BuiltInFailuresMEPFabricationFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberAdditionalPartNotLoaded An additional part was not loaded.
Public propertyStatic memberCannotConvertFlexPipeToPart Cannot convert flex pipe to fabrication part.
Public propertyStatic memberCannotMatchFabricationHangerSizeToHost The hanger cannot be re-sized to match the re-sized host.
Public propertyStatic memberFabDbChangeConn Fabrication Database changes altered connectivity
Public propertyStatic memberFabDbOpenJobConn Fabrication job imported had bad connectivity
Public propertyStatic memberFabDbSwapOut Fabrication Database reload could not swap out for newer parts.
Public propertyStatic memberFabricationConfigurationCorrupted It looks that the Fabrication Configuration %1!s! was corrupted, please check it at %2!s!.
Public propertyStatic memberFabricationHangerCannotBeSloped A hanger cannot be sloped or placed on a sloped element.
Public propertyStatic memberFabricationHangerHostNotFound The hanger will disconnect because we can't find the suitable host.
Public propertyStatic memberFabricationHangerNotConnectToHost Fabrication Hanger didn't connect to the %s host.
Public propertyStatic memberFabricationHangerOutOfHost The hanger is out of its host and will be disconnected.
Public propertyStatic memberFabricationHangerSizeNotMatch The hanger size does not match the size of the host, so it can not be connected.
Public propertyStatic memberFabricationOutOfSizeCondition The fabrication part size is not within the correct size range for the service button condition.
Public propertyStatic memberFabricationOverSizedCheck Fabrication part is too large to fit on the sheet metal. Replace the part with multiple smaller parts, or notify the CAM operator.
Public propertyStatic memberFabricationPartBadConnectionAlignmentWarning The connection invalid due to the connector are not aligned and/or this is a gap between the connectors.
Public propertyStatic memberFabricationPartBadConnectionConnectivityWarning The connection invalid due to connection types associated to the connectors are not compatible.
Public propertyStatic memberFabricationPartBadConnectionSizeWarning The connection invalid due to connectors sizes are not the same.
Public propertyStatic memberFabricationPartCannotBeMirrored 
Public propertyStatic memberFabricationPartCannotChangeServiceSizeWarning The selected fitting(s) cannot successfully change service or change size. You must disconnect the connections on the fitting(s) and try again.
Public propertyStatic memberFabricationPartCannotChangeSlopeError The connected fitting(s) cannot successfully change to the new slope value. You may try to disconnect the connections on the fitting(s) and try again.
Public propertyStatic memberFabricationPartCannotChangeTypeBadDimError The selected fitting(s) cannot successfully change the type. The newly selected fabrication part may have badly configured dimensions or be constrained due to connected fitting(s). You may try to disconnect the connections on the fitting(s) and try again.
Public propertyStatic memberFabricationPartCannotChangeTypeBadDimUnConnError The selected fitting(s) cannot successfully change the type. The newly selected fabrication part may have badly configured dimensions, resulting in bad geometry.
Public propertyStatic memberFabricationPartCannotChangeTypeError The selected fitting(s) cannot successfully change the type. You must disconnect the connections on the fitting(s) and try again.
Public propertyStatic memberFabricationPartCannotChangeTypeIncompatError The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type either has no material or has badly configured dimensions, resulting in bad geometry. You may try to disconnect the connections on the fitting(s) and try again.
Public propertyStatic memberFabricationPartCannotChangeTypeIncompatUnConnError The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type either has no material or has badly configured dimensions, resulting in bad geometry.
Public propertyStatic memberFabricationPartCannotChangeTypeMisalignedError The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type has a problem with the angle dimension of the current fitting(s), resulting in bad geometry. You may try to disconnect the connections on the fitting(s) and try again.
Public propertyStatic memberFabricationPartCannotChangeTypeMisalignedUnConnError The selected fitting(s) cannot successfully change the type. The newly selected fabrication part type has a problem with the angle dimension of the current fitting(s), resulting in bad geometry.
Public propertyStatic memberFabricationPartCannotChangeTypeUnConnError The selected fitting(s) cannot successfully change the type.
Public propertyStatic memberFabricationPartCannotChangeTypeWarning The selected fitting(s) cannot maintain connections to existing fabrication parts due to size, direction or angle differences. You must manually reconnect the open connections.
Public propertyStatic memberFabricationPartExceededAngleFlexToleranceWarning The angle flex is greater than the maximum angle flex tolerance defined by the fabrication part. Connections with this part may not be properly aligned and may appear to be skewed.
Public propertyStatic memberFabricationPartExcludedPartWarning There were fabrication parts needed to the make the connection that were excluded from the fabrication service causing the connection to fail. You may try to inlcude these fitting(s) and try again.
Public propertyStatic memberFabricationPartFitFailure Fabrication Part Fitting Failed to Fit
Public propertyStatic memberFabricationPartFitFailWarning Fabrication Part Fitting Failed to Fit
Public propertyStatic memberFabricationPartHasInvalidGeometry The fabrication part either has no material or has badly configured dimensions, resulting in bad geometry.
Public propertyStatic memberFabricationPartInvalidConnection Fabrication Part connection invalid and could not be automatically coupled.
Public propertyStatic memberFabricationPartInvalidSpecification The part specification is invalid.
Public propertyStatic memberFabricationPartNoPartTypeFound There are no fabrication part types found for the current Configuration and Service. Please select settings and reload the service to create the fabrication part types.
Public propertyStatic memberFabricationPartNotAttachedToStraight The part must be attached to straight.
Public propertyStatic memberFabricationPartOptimizeInvalidConnection No available couplings to connect standard lengths for this instance of straight.
Public propertyStatic memberFabricationRodDetachFromHangerError The rod need to be detached from hanger.
Public propertyStatic memberFabricationRodsConnectionChangedWarning The structural component that the hanger is attached to has changed to a different element.
Public propertyStatic memberFabricationRodsDisconnectedError The hanger rod was disconnected because there is no structural component above.
Public propertyStatic memberFabricationRodsDisconnectedWarning The hanger rod was disconnected because there is no structural component above.
Public propertyStatic memberFabricationServiceMismatch Attempting to connect fabrication parts from different services.
Public propertyStatic memberFabricationStraigtLengthOversized Fabrication straight exceeds the standard length. Use the Optimize Length command to adjust the length.
Public propertyStatic memberFixedFabricationPartNotChangeLength Failed to change length of fixed part.
Public propertyStatic memberGroupedFabricationPartNotReposition Failed to reposition part.
Public propertyStatic memberHangerProfileNotMatchWithHost The defined hanger profile does not match with the host.
Public propertyStatic memberHangerWidthOutOfRange The hanger width is too large to show.
Public propertyStatic memberInvalidConnectionsHaveBeenDisconnected Invalid connections have been disconnected. Please reconnect them manually or use different fittings.
Public propertyStatic memberInvalidSelectionThereCannotBeOpenConnectors Invalid selection there cannot be any open connectors for the design to fabrication part tool.
Public propertyStatic memberNoStructuralHostToAttachWarning There is no structural component to attach the hanger rod to.
Public propertyStatic memberNotAllPartsWereConvertedUnsuportedFittingOffsets Not all parts were converted. Eccentric transitions and taps that have offsets from the center line are unsupported and cannot be converted.
Public propertyStatic memberPinnedFabricationPartNotChangeExtension Failed to change extension of part.
Public propertyStatic memberPinnedFabricationPartNotReposition Failed to reposition part.
Public propertyStatic memberPlaceCutinFittingFailed Failed to insert part.
Public propertyStatic memberSizeNotAvailableInFabricationService Sizes:%1!s! in system %2!s! are not available in fabrication service:%3!s!, All available sizes are:\n%4!s!.
Public propertyStatic memberUneditableFabricationPartNotReposition Failed to reposition part.
Top
See Also